using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\G(?!^)|\()([^)\s]*)\s+";
string substitution = @"$1$2";
string input = @"foobar baz blah (some sample text in here) and some more
a b c (d e f) g ( )";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}