import Foundation
let pattern = #"(\G(?!^)|\()([^)\s]*)\s+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foobar baz blah (some sample text in here) and some more
a b c (d e f) g ( )
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)