import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{ queryRunner \\}, ([\\n\\{\\}A-Za-z0-9., :]*)\\{\\n*\\s*user,*(: [a-zA-Z,]+)?\\n*\\s*\\} as ContextWithUser";
final String string = "const updatedEvent2 = await Resolver.updateEvent(\n"
+ " { queryRunner }, \n"
+ " { ...updatedEvent1 }, \n"
+ " { user: host } as ContextWithUser, \n"
+ " null\n"
+ ");\n\n"
+ "const updatedEvent2 = await Resolver.updateEvent({ queryRunner }, { ...updatedEvent1 }, { user } as ContextWithUser, null);\n\n"
+ "await Resolver.updateEventResponse({ queryRunner }, { id: eventResponse.id, type: ResponseType.yes }, { user } as ContextWithUser);\n\n"
+ "const updatedEventResponse = await Resolver.updateEventResponse({ queryRunner }, { id: eventResponse.id, type: ResponseType.no }, {\n"
+ " user: host,\n"
+ " } as ContextWithUser);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}