import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Project\\(\"(?<Guid1>\\{[\\w-]+\\})\"\\)\\s*=\\s*\"(?<ProjectName>[\\w\\.]+)\",\\s*\"(?<Path>.+)\"\\s*,\\s\"(?<Guid2>\\{[\\w-]+\\})\"";
final String string = "Project(\"{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}\") = \"Logger.Core\", \"..\\..\\Logger\\Development\\Logger.Core\\Logger.Core.csproj\", \"{07095870-CF46-45F4-8E84-8B3C586BBF44}\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}