// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"Project\("(?<Guid1>\{[\w-]+\})"\)\s*=\s*"(?<ProjectName>[\w\.]+)",\s*"(?<Path>.+)"\s*,\s"(?<Guid2>\{[\w-]+\})""#).unwrap();
let string = "Project(\"{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}\") = \"Logger.Core\", \"..\\..\\Logger\\Development\\Logger.Core\\Logger.Core.csproj\", \"{07095870-CF46-45F4-8E84-8B3C586BBF44}\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}