using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\w ]\()([^;\n]|"".*?"")*(?=\))";
string input = @"foo(() ((hello) world))
bar (hello world!)
baz(ddd(()))
bazbaz(dsadsa"")"" dsada)
bazbaz(dsadsa"")"" d(()(das))das)das)ds)a(d(sa(d)()()sada); ;; d(ssss)
bazbaz("") "" d "" ;"" );
h(dsaqwd)
h(dsaqwd);h(dsaqwd)
h(dsaqwd); h(dsaqwd);
foo(() ((hello) world)); bar(gffjdk)
f(""a;"");g(""b"");
f(""a;\"");g(""b"");";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}