import re
regex = re.compile(r"""
(?<=[\w ]\()([^;\n]|".*?")*(?=\))
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("foo(() ((hello) world))\n"
"bar (hello world!)\n"
"baz(ddd(()))\n\n"
"bazbaz(dsadsa\")\" dsada)\n"
"bazbaz(dsadsa\")\" d(()(das))das)das)ds)a(d(sa(d)()()sada); ;; d(ssss)\n\n"
"bazbaz(\") \" d \" ;\" );\n\n"
"h(dsaqwd)\n"
"h(dsaqwd);h(dsaqwd)\n"
"h(dsaqwd); h(dsaqwd);\n\n"
"foo(() ((hello) world)); bar(gffjdk)\n\n"
"f(\"a;\");g(\"b\");\n"
"f(\"a;\\\"\");g(\"b\");")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")