using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s|\G)\d+?\K(?=(?:\d{3})+(?!\S))";
string substitution = @",";
string input = @"403
123456
55324673 cups of tea and 1564 polar bears
ABC123131";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}