const regex = /(?:\s|\G)\d+?\K(?=(?:\d{3})+(?!\S))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s|\\G)\\d+?\\K(?=(?:\\d{3})+(?!\\S))', 'g')
const str = `403
123456
55324673 cups of tea and 1564 polar bears
ABC123131`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);