use strict;
my $str = '403
123456
55324673 cups of tea and 1564 polar bears
ABC123131';
my $regex = qr/(?:\s|\G)\d+?\K(?=(?:\d{3})+(?!\S))/p;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";