#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=([iI]{1}\s[aA]{1}[mM']{1}\s)|([iI]{1}[mM]{1})|([iI]{1}[']{1}[mM]{1})).*(?=(0?[1-9]{1}|[1]{1}[0-7]{1})(\s|[-])?(y(\s?)o|yr([sz]?)|year([sz]?)((\s|[-])?(old)?)|y)((\s?|[-])(old)?))"
Local $sString = "im " & @CRLF & _
"Im" & @CRLF & _
"IM" & @CRLF & _
"I am 17yo" & @CRLF & _
"iam" & @CRLF & _
"I AM almost 15yo" & @CRLF & _
"Im going to be 14 years old" & @CRLF & _
"I am going to be 14 years old" & @CRLF & _
"i am" & @CRLF & _
"i ma " & @CRLF & _
"i man" & @CRLF & _
"i'm" & @CRLF & _
"I'm" & @CRLF & _
"I'M"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")