import re
regex = re.compile(r"(?<=([iI]{1}\s[aA]{1}[mM']{1}\s)|([iI]{1}[mM]{1})|([iI]{1}[']{1}[mM]{1})).*(?=(0?[1-9]{1}|[1]{1}[0-7]{1})(\s|[-])?(y(\s?)o|yr([sz]?)|year([sz]?)((\s|[-])?(old)?)|y)((\s?|[-])(old)?))", flags=re.MULTILINE)
test_str = ("im \n"
"Im\n"
"IM\n"
"I am 17yo\n"
"iam\n"
"I AM almost 15yo\n"
"Im going to be 14 years old\n"
"I am going to be 14 years old\n"
"i am\n"
"i ma \n"
"i man\n"
"i'm\n"
"I'm\n"
"I'M")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")