import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=([iI]{1}\\s[aA]{1}[mM']{1}\\s)|([iI]{1}[mM]{1})|([iI]{1}[']{1}[mM]{1})).*(?=(0?[1-9]{1}|[1]{1}[0-7]{1})(\\s|[-])?(y(\\s?)o|yr([sz]?)|year([sz]?)((\\s|[-])?(old)?)|y)((\\s?|[-])(old)?))";
final String string = "im \n"
+ "Im\n"
+ "IM\n"
+ "I am 17yo\n"
+ "iam\n"
+ "I AM almost 15yo\n"
+ "Im going to be 14 years old\n"
+ "I am going to be 14 years old\n"
+ "i am\n"
+ "i ma \n"
+ "i man\n"
+ "i'm\n"
+ "I'm\n"
+ "I'M";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}