using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=([iI]{1}\s[aA]{1}[mM']{1}\s)|([iI]{1}[mM]{1})|([iI]{1}[']{1}[mM]{1})).*(?=(0?[1-9]{1}|[1]{1}[0-7]{1})(\s|[-])?(y(\s?)o|yr([sz]?)|year([sz]?)((\s|[-])?(old)?)|y)((\s?|[-])(old)?))";
string input = @"im
Im
IM
I am 17yo
iam
I AM almost 15yo
Im going to be 14 years old
I am going to be 14 years old
i am
i ma
i man
i'm
I'm
I'M";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}