const regex = /(?<=([iI]{1}\s[aA]{1}[mM']{1}\s)|([iI]{1}[mM]{1})|([iI]{1}[']{1}[mM]{1})).*(?=(0?[1-9]{1}|[1]{1}[0-7]{1})(\s|[-])?(y(\s?)o|yr([sz]?)|year([sz]?)((\s|[-])?(old)?)|y)((\s?|[-])(old)?))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=([iI]{1}\\s[aA]{1}[mM\']{1}\\s)|([iI]{1}[mM]{1})|([iI]{1}[\']{1}[mM]{1})).*(?=(0?[1-9]{1}|[1]{1}[0-7]{1})(\\s|[-])?(y(\\s?)o|yr([sz]?)|year([sz]?)((\\s|[-])?(old)?)|y)((\\s?|[-])(old)?))', 'gm')
const str = `im
Im
IM
I am 17yo
iam
I AM almost 15yo
Im going to be 14 years old
I am going to be 14 years old
i am
i ma
i man
i'm
I'm
I'M`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}