using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0[1-9]|[12][0-9]|3[01])(\/|-)?(0[1-9]|1[012])(((\/)?([0-9]{4}|[0-9]{2}))|((\/|-)?[0-9]{4}))$";
string input = @"13/10/2022
10/10/2022
13/10/22
10/10/22
13-10-2022
10-10-2022
13-10-22
10-10-22
131022
101022
13102022
10102022
20221013
20221010
2022-10-13
2022-10-10
2022/10/13
2022/10/10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}