const regex = /^(0[1-9]|[12][0-9]|3[01])(\/|-)?(0[1-9]|1[012])(((\/)?([0-9]{4}|[0-9]{2}))|((\/|-)?[0-9]{4}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0[1-9]|[12][0-9]|3[01])(\\\/|-)?(0[1-9]|1[012])(((\\\/)?([0-9]{4}|[0-9]{2}))|((\\\/|-)?[0-9]{4}))$', 'gm')
const str = `13/10/2022
10/10/2022
13/10/22
10/10/22
13-10-2022
10-10-2022
13-10-22
10-10-22
131022
101022
13102022
10102022
20221013
20221010
2022-10-13
2022-10-10
2022/10/13
2022/10/10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}