import re
regex = re.compile(r"^(0[1-9]|[12][0-9]|3[01])(\/|-)?(0[1-9]|1[012])(((\/)?([0-9]{4}|[0-9]{2}))|((\/|-)?[0-9]{4}))$", flags=re.MULTILINE)
test_str = ("13/10/2022\n"
"10/10/2022\n"
"13/10/22\n"
"10/10/22\n"
"13-10-2022\n"
"10-10-2022\n"
"13-10-22\n"
"10-10-22\n"
"131022\n"
"101022\n"
"13102022\n"
"10102022\n"
"20221013\n"
"20221010\n"
"2022-10-13\n"
"2022-10-10\n"
"2022/10/13\n"
"2022/10/10")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")