#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*(M6[^_]*).*"
Local $sString = "" & @CRLF & _
"HEY01230328_M6K21SG_UNO_NYC_241" & @CRLF & _
"M6EW2BJ_UNO_NYC_251" & @CRLF & _
"M6HW2WL_UNO_NYC_251" & @CRLF & _
"HEY08460329_NA_M6LAB3D_UNO_NYC_241"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")