package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*(M6[^_]*).*`)
var str = `
HEY01230328_M6K21SG_UNO_NYC_241
M6EW2BJ_UNO_NYC_251
M6HW2WL_UNO_NYC_251
HEY08460329_NA_M6LAB3D_UNO_NYC_241`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}