import re
regex = re.compile(r".*(M6[^_]*).*", flags=re.MULTILINE)
test_str = ("\n"
"HEY01230328_M6K21SG_UNO_NYC_241\n"
"M6EW2BJ_UNO_NYC_251\n"
"M6HW2WL_UNO_NYC_251\n"
"HEY08460329_NA_M6LAB3D_UNO_NYC_241")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")