import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(M6[^_]*).*";
final String string = "\n"
+ "HEY01230328_M6K21SG_UNO_NYC_241\n"
+ "M6EW2BJ_UNO_NYC_251\n"
+ "M6HW2WL_UNO_NYC_251\n"
+ "HEY08460329_NA_M6LAB3D_UNO_NYC_241";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}