using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(ISBN[-]*(1[03])*[ ]*(: ){0,1})*(([0-9Xx][- ]*){13}|([0-9Xx][- ]*){10})";
string input = @"In his groundbreaking book, ""The Theory of Everything,"" Stephen Hawking explores the fundamental principles that govern the universe. This book, with ISBN 978-0553380163 (or the 10-digit version 9780553380163), delves into complex topics such as black holes, the Big Bang, and the nature of time, making them accessible to a general audience.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}