// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(ISBN[-]*(1[03])*[ ]*(: ){0,1})*(([0-9Xx][- ]*){13}|([0-9Xx][- ]*){10})").unwrap();
let string = "In his groundbreaking book, \"The Theory of Everything,\" Stephen Hawking explores the fundamental principles that govern the universe. This book, with ISBN 978-0553380163 (or the 10-digit version 9780553380163), delves into complex topics such as black holes, the Big Bang, and the nature of time, making them accessible to a general audience.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}