#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*\baaa\b)(?=.*\bbbb\b)(?=.*\bccc\b)(?!.*?\b(\w+)\b.*?\1)(?:(?:aaa|ccc|bbb)[ \t]?)+$"
Local $sString = "aaa ccc bbb" & @CRLF & _
"aaa bbb ccc" & @CRLF & _
"aaa ccc" & @CRLF & _
"aaa bbb ddd ccc" & @CRLF & _
"bbb aaa bbb ccc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")