using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\baaa\b)(?=.*\bbbb\b)(?=.*\bccc\b)(?!.*?\b(\w+)\b.*?\1)(?:(?:aaa|ccc|bbb)[ \t]?)+$";
string input = @"aaa ccc bbb
aaa bbb ccc
aaa ccc
aaa bbb ddd ccc
bbb aaa bbb ccc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}