const regex = /^(?=.*\baaa\b)(?=.*\bbbb\b)(?=.*\bccc\b)(?!.*?\b(\w+)\b.*?\1)(?:(?:aaa|ccc|bbb)[ \t]?)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\baaa\\b)(?=.*\\bbbb\\b)(?=.*\\bccc\\b)(?!.*?\\b(\\w+)\\b.*?\\1)(?:(?:aaa|ccc|bbb)[ \\t]?)+$', 'gm')
const str = `aaa ccc bbb
aaa bbb ccc
aaa ccc
aaa bbb ddd ccc
bbb aaa bbb ccc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}