import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\baaa\\b)(?=.*\\bbbb\\b)(?=.*\\bccc\\b)(?!.*?\\b(\\w+)\\b.*?\\1)(?:(?:aaa|ccc|bbb)[ \\t]?)+$";
final String string = "aaa ccc bbb\n"
+ "aaa bbb ccc\n"
+ "aaa ccc\n"
+ "aaa bbb ddd ccc\n"
+ "bbb aaa bbb ccc";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}