$re = '/^(?=.*\baaa\b)(?=.*\bbbb\b)(?=.*\bccc\b)(?!.*?\b(\w+)\b.*?\1)(?:(?:aaa|ccc|bbb)[ \t]?)+$/m';
$str = 'aaa ccc bbb
aaa bbb ccc
aaa ccc
aaa bbb ddd ccc
bbb aaa bbb ccc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);