#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)<mj-image([^>/]*)>([^]*?)<\/mj-image>"
Local $sString = "<mj-image-variable variable="user.image_url"></mj-image-variable>" & @CRLF & _
"<mj-image></mj-image>" & @CRLF & _
"<mj-image src="https://example.com/image.png"></mj-image>" & @CRLF & _
"<mj-image" & @CRLF & _
" src="https://example.com/image.png"" & @CRLF & _
"></mj-image>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")