import Foundation
let pattern = #"<mj-image([^>/]*)>([^]*?)<\/mj-image>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<mj-image-variable variable="user.image_url"></mj-image-variable>
<mj-image></mj-image>
<mj-image src="https://example.com/image.png"></mj-image>
<mj-image
src="https://example.com/image.png"
></mj-image>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)