use strict;
my $str = '<mj-image-variable variable="user.image_url"></mj-image-variable>
<mj-image></mj-image>
<mj-image src="https://example.com/image.png"></mj-image>
<mj-image
src="https://example.com/image.png"
></mj-image>';
my $regex = qr/<mj-image([^>/]*)>([^]*?)<\/mj-image>/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}