const regex = /<mj-image([^>/]*)>([^]*?)<\/mj-image>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<mj-image([^>\/]*)>([^]*?)<\\\/mj-image>', 'gmi')
const str = `<mj-image-variable variable="user.image_url"></mj-image-variable>
<mj-image></mj-image>
<mj-image src="https://example.com/image.png"></mj-image>
<mj-image
src="https://example.com/image.png"
></mj-image>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}