# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<img .*?imgur\.com(.*?))(?=\\/?\s?>)/$1 class="newClass"/gm;t' <<< "I have been searching <img src=\"https://i.imgur.com/NknpNdu.jpg\" alt=\"\"> for... I have been searching <img src=\"https://i.imgur.com/NknpNdu.jpg\" alt=\"\"> for... I have been searching <img src=\"https://i.imgur.com/NknpNdu.jpg\" alt=\"\"> for... I have been searching <img src=\"https://i.imgur.com/NknpNdu.jpg\" alt=\"\" /> for... "