re = /(<img .*?imgur\.com(.*?))(?=\/?\s?>)/m
str = 'I have been searching <img src="https://i.imgur.com/NknpNdu.jpg" alt=""> for... I have been searching <img src="https://i.imgur.com/NknpNdu.jpg" alt=""> for... I have been searching <img src="https://i.imgur.com/NknpNdu.jpg" alt=""> for... I have been searching <img src="https://i.imgur.com/NknpNdu.jpg" alt="" /> for... '
subst = '$1 class="newClass"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result