const regex = /(<img .*?imgur\.com(.*?))(?=\/?\s?>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<img .*?imgur\\.com(.*?))(?=\\\/?\\s?>)', 'gm')
const str = `I have been searching <img src="https://i.imgur.com/NknpNdu.jpg" alt=""> for... I have been searching <img src="https://i.imgur.com/NknpNdu.jpg" alt=""> for... I have been searching <img src="https://i.imgur.com/NknpNdu.jpg" alt=""> for... I have been searching <img src="https://i.imgur.com/NknpNdu.jpg" alt="" /> for... `;
const subst = `$1 class="newClass"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);