$re = '/(<img .*?imgur\.com(.*?))(?=\/?\s?>)/m';
$str = 'I have been searching <img src="https://i.imgur.com/NknpNdu.jpg" alt=""> for... I have been searching <img src="https://i.imgur.com/NknpNdu.jpg" alt=""> for... I have been searching <img src="https://i.imgur.com/NknpNdu.jpg" alt=""> for... I have been searching <img src="https://i.imgur.com/NknpNdu.jpg" alt="" /> for... ';
$subst = "$1 class=\"newClass\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;