import re
regex = re.compile(r"(<img .*?imgur\.com(.*?))(?=\/?\s?>)", flags=re.MULTILINE)
test_str = "I have been searching <img src=\"https://i.imgur.com/NknpNdu.jpg\" alt=\"\"> for... I have been searching <img src=\"https://i.imgur.com/NknpNdu.jpg\" alt=\"\"> for... I have been searching <img src=\"https://i.imgur.com/NknpNdu.jpg\" alt=\"\"> for... I have been searching <img src=\"https://i.imgur.com/NknpNdu.jpg\" alt=\"\" /> for... "
subst = "$1 class=\"newClass\""
result = regex.sub(subst, test_str)
if result:
print(result)