#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.{51,}).{1,}?@.{4,}?$"
Local $sString = "@1234" & @CRLF & _
"1@123" & @CRLF & _
"1@1234" & @CRLF & _
"1234567890@123456789012345678901234567890123456789" & @CRLF & _
"1234567890@1234567890123456789012345678901234567890"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")