import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.{51,}).{1,}?@.{4,}?$";
final String string = "@1234\n"
+ "1@123\n"
+ "1@1234\n"
+ "1234567890@123456789012345678901234567890123456789\n"
+ "1234567890@1234567890123456789012345678901234567890";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}