import re
regex = re.compile(r"^(?!.{51,}).{1,}?@.{4,}?$", flags=re.MULTILINE)
test_str = ("@1234\n"
"1@123\n"
"1@1234\n"
"1234567890@123456789012345678901234567890123456789\n"
"1234567890@1234567890123456789012345678901234567890")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")