import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?is)(?<=([a-z])\\s)(\\1)([a-z]*)";
final String string = "word dark king glow we end hello bye low wing\n"
+ "word Dark King Glow We End hello bye LoW wing\n"
+ "A a A b B C c C C";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}