const regex = /(?is)(?<=([a-z])\s)(\1)([a-z]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?is)(?<=([a-z])\\s)(\\1)([a-z]*)', 'g')
const str = `word dark king glow we end hello bye low wing
word Dark King Glow We End hello bye LoW wing
A a A b B C c C C`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}