import re
regex = re.compile(r"(?is)(?<=([a-z])\s)(\1)([a-z]*)")
test_str = ("word dark king glow we end hello bye low wing\n"
"word Dark King Glow We End hello bye LoW wing\n"
"A a A b B C c C C")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")