re = /(?is)(?<=([a-z])\s)(\1)([a-z]*)/
str = 'word dark king glow we end hello bye low wing
word Dark King Glow We End hello bye LoW wing
A a A b B C c C C'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end