#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[ ]*(.+):[ ]*\n?((?:.+\n?[^\s])*)"
Local $sString = "Alpha:" & @CRLF & _
"Lorem ipsum" & @CRLF & _
"" & @CRLF & _
"Beta gamma:" & @CRLF & _
"dolor sit amet" & @CRLF & _
"consectetur adipiscing" & @CRLF & _
"elit" & @CRLF & _
"" & @CRLF & _
"delta: quam vehicula " & @CRLF & _
"" & @CRLF & _
"Epsilon:-Zeta:" & @CRLF & _
"Curabitur interdum massa" & @CRLF & _
"" & @CRLF & _
" Eta:" & @CRLF & _
"Maecenas ac felis" & @CRLF & _
"" & @CRLF & _
"Theta:" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Iota: " & @CRLF & _
"Morbi at lobortis"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")