$re = '/[ ]*(.+):[ ]*\n?((?:.+\n?[^\s])*)/m';
$str = 'Alpha:
Lorem ipsum
Beta gamma:
dolor sit amet
consectetur adipiscing
elit
delta: quam vehicula
Epsilon:-Zeta:
Curabitur interdum massa
Eta:
Maecenas ac felis
Theta:
Iota:
Morbi at lobortis';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);