import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[ ]*(.+):[ ]*\\n?((?:.+\\n?[^\\s])*)";
final String string = "Alpha:\n"
+ "Lorem ipsum\n\n"
+ "Beta gamma:\n"
+ "dolor sit amet\n"
+ "consectetur adipiscing\n"
+ "elit\n\n"
+ "delta: quam vehicula \n\n"
+ "Epsilon:-Zeta:\n"
+ "Curabitur interdum massa\n\n"
+ " Eta:\n"
+ "Maecenas ac felis\n\n"
+ "Theta:\n\n\n\n"
+ "Iota: \n"
+ "Morbi at lobortis";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}