using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[ ]*(.+):[ ]*\n?((?:.+\n?[^\s])*)";
string input = @"Alpha:
Lorem ipsum
Beta gamma:
dolor sit amet
consectetur adipiscing
elit
delta: quam vehicula
Epsilon:-Zeta:
Curabitur interdum massa
Eta:
Maecenas ac felis
Theta:
Iota:
Morbi at lobortis";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}