// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[ ]*(.+):[ ]*\n?((?:.+\n?[^\s])*)").unwrap();
let string = "Alpha:
Lorem ipsum
Beta gamma:
dolor sit amet
consectetur adipiscing
elit
delta: quam vehicula
Epsilon:-Zeta:
Curabitur interdum massa
Eta:
Maecenas ac felis
Theta:
Iota:
Morbi at lobortis";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}